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声明 Statement 

本文件所含数据和信息都属于紫光展锐所有的机密信息，紫光展锐保留所有相关权利。本文件仅

为信息参考之目的提供，不包含任何明示或默示的知识产权许可，也不表示有任何明示或默示的保证，

包括但不限于满足任何特殊目的、不侵权或性能。当您接受这份文件时，即表示您同意本文件中内容

和信息属于紫光展锐机密信息，且同意在未获得紫光展锐书面同意前，不使用或复制本文件的整体或

部分，也不向任何其他方披露本文件内容。紫光展锐有权在未经事先通知的情况下，在任何时候对本

文件做任何修改。紫光展锐对本文件所含数据和信息不做任何保证，在任何情况下，紫光展锐均不负

责任何与本文件相关的直接或间接的、任何伤害或损失。   

All data and information contained in or disclosed by this document is confidential and 

proprietary information of UNISOC and all rights therein are expressly reserved. This 

document is provided for reference purpose, no license (express or implied, by estoppel or 

otherwise) to any intellectual property rights is granted by this document, and no express 

and implied warranties, including but without limitation, the implied warranties of fitness for 

any particular purpose, and non-infringement, as well as any performance. By accepting this 

material, the recipient agrees that the material and the information contained therein is to be 

held in confidence and in trust and will not be used, copied, reproduced in whole or in part, 

nor its contents revealed in any manner to others without the express written permission of 

UNISOC. UNISOC may make any changes at any time without prior notice. Although every 

reasonable effort is made to present current and accurate information, UNISOC makes no 
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guarantees of any kind with respect to the matters addressed in this document. In no event 

shall UNISOC be responsible or liable, directly or indirectly, for any damage or loss caused or 

alleged to be caused by or in connection with the use of or reliance on any such content. 
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前  言 

一 范围 Scope 

本文详细介绍了 Coolwatcher 的基本功能与使用说明，适用于 Coolwatcher 使用人员。 
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1. 定义 Definitions 
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3. 缩略语 Abbreviations 
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1.概览 Overview 

1.1 文档概要 

    本文档详细介绍了 Coolwatcher 的基本功能与使用说明，包括硬件配置、软件配置、使用步骤、

故障处理等。 

1.2 目标设定 

    Coolwatcher 工具使用人员，可以熟练、正确使用 Coolwatcher 的各项功能，以便于为后续分析、

解决问题提供帮助。 

 

2. 环境配置介绍 

2.1 软件安装 

 Coolwatcher 是绿色软件，无需安装，将压缩包解压到某个子目录下即可使用。注意解压路径中，

不要含有中文字符。 

2.2 运行环境 

建议计算机配置内存 4G 以上、处理器双核以上， 需确保安装相应的串口驱动，以保证模块/手机

可与 PC 成功连接并通讯。 

    可支持的 PC 系统版本包括 Windows XP/7/10 等，linux 系统仅支持 ubuntu16.04。 

2.3 license  

见 notice.txt 文件。 
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3. 安装与设置 

coolwatcher 分为 coolwatcher_debughost.exe 和 coolwatcher_usb.exe，二者的通信方式不

同。 

coolwatcher_debughost.exe 为 debughost 方式，PC 机和模块之间需要 usb 转串口线(模块)

相连，需安装 usb 转串口线(模块)的对应驱动。 

coolwatcher_usb.exe 为 usb 方式，PC 机和模块直接用数据线相连，需安装 usb 驱动。usb 方

式个别模块不支持。 

3.1 Debughost 方式 

3.1.1 Windows 系统 

    以 8910 的 usb 转串口 ftdi 模块为例进行相关介绍。 

3.1.1.1 驱动安装 

根据 usb 转串口模块安装对应驱动。 

PC 通过 usb 转串口模块/线与模块相连，如果 usb 转串口模块为 ftdi 模块，则安装

drivers\ftdi\2.12.16 路径下的驱动。 

驱动安装完毕后，端口号可通过“计算机->管理->设备管理器->端口”进行查看。 

 
图 3-1-1 端口示意图 
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3.1.1.2 判断端口 

如何判断哪个端口与 coolwather 相连？ 一般情况为图 3-1-1 的第二个端口；如果连接失败，则

通过硬件 Id 来识别通信端口。 

设备管理—>端口(COM 和 LPT) —>找名称为 USB Serial Port(COM*)的端口。右键菜单，点击

属性，打开端口属性对话框。切换到详细信息页面，属性列表中选择硬件 ID，察看 id 信息。   

 

图 3-1-2 右键菜单属性项 
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图 3-1-3 察看硬件 Id (一) 

 

 

图 3-1-4 察看硬件 Id (二) 

   硬件 Id 信息如图 3-1-4 的端口为模块与 coolwather 的通信端口。 
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3.1.2 ubuntu16.04 系统 

3.1.2.1 依赖包安装 

     依赖包 

     用 sudo apt install 命令逐个安装 build-essential、libqt4-qt3support、 itcl3、itk3、iwidgets4 

     99-coolsand-dongle.rules 文件 

 把 99-coolsand-dongle.rules 文件放到 /etc/udev/rules.d/路径中 

3.1.2.2 配置端口 

在应用程序 coolwatcher_*.exe 所在文件夹中建立子文件夹 comport。 

在 comport 文件夹中，为端口对应的/dev/ttyUSB0、/dev/ttyUSB1 、/dev/ttyUSB*创建符号

连接文件。举例如下: 

  如 ln –s /dev/ttyUSB0  comport/COM1 

   ln –s /dev/ttyUSB1  comport/COM2 

注意 COM1、COM2 字母需大写。 

    软链接建立的端口号需为 1~255 之间，即 COM1、COM2 … COM255。 

3.2 USB 方式 

 

目前仅 8910 支持 USB 方式。 
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3.2.1 Windows 系统 

安装 DTKWin\drivers\8910usb 文件夹中的驱动, 建议安装前先连接 PC 和 8910 模块。驱动安

装完成后，可在设备管理器中看到 8 个 USB 端口；Port4 为模块与 coolwatcher 通信的端口。 

   
图 3-2-1 8910 USB 端口 

3.2.2 Ubuntu16.04 系统 

3.2.2.1 驱动说明 

     使用自带驱动即可。 

      USB 串口没有标准 CLASS，在 Linux 要根据 PID/VID 去识别。 

 在命令行下配置 

a) 挂载 option 驱动 

/sbin/modprobe option 

b) 把 8910 可能用到的模式加入 option 驱动的识别列表 

echo 1782 4d10 ff > /sys/bus/usb-serial/drivers/option/new_id 

echo 1782 4d11 ff > /sys/bus/usb-serial/drivers/option/new_id 

 修改 Kernel 代码 

需要修改的文件为 drivers/usb/serial/option.c，在 option_ids 里增加： 
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// Eight Serials 

{ USB_DEVICE_AND_INTERFACE_INFO(0x1782, 0x4d10, 0xff, 0, 0) }, 

// netdev and four serials 

{ USB_DEVICE_AND_INTERFACE_INFO(0x1782, 0x4d11, 0xff, 0, 0) }, 

// diag device, 同上，可以不用 

{ USB_DEVICE_AND_INTERFACE_INFO(0x1782, 0x4d11, 0xff, 0, 0) } 

3.2.2.2 端口说明 

 识别端口 

     插入usb 线，在/dev/文件夹可以看到 ttyUSB{*}，对于pid 4d10，一般情况是ttyUSB0、ttyUSB1、…、

ttyUSB7。 

     因 Linux 下 tty 设备不显示设备名称，所以需要使用 udevinfo 来确认具体设备对应端口。 

           udevadm info –n /dev/ttyUSB{0-7} 

     看其中的 ID_USB_INTERFACE_NUM=${id}：对于 pid 4d10，id 是 0-7，8910 模块与

coolwatcher 通信的端口一般为 ttyUSB4；对于 pid 4d11，id 是 2-9,  8910 模块与 coolwatcher

通信的端口一般为 ttyUSB6。他们从小到大依次对应 Windows 下的 *Port0 - *Port7。 

 适配 coolwatcher 

 在应用程序 coolwatcher_*.exe 所在文件夹中建立子文件夹 comport。 

 在 comport 文件夹中，为端口对应的/dev/ttyUSB0、/dev/ttyUSB1 、/dev/ttyUSB*创建符号

连接文件。举例如下: 

  如 
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   ln –s /dev/ttyUSB4  comport/COM5  //  pid 4d10 

   or  ln –s /dev/ttyUSB6  comport/COM7  // pid 4d11 

注意 COM5、COM7 字母需大写。 

软链接建立的端口号需为 1~255 之间，即 COM1、COM2 … COM255。   

3.3 启动 Coolwatcher 

    coolwatcher_debughost.exe/ coolwatcher_usb.exe 的启动和运行及功能操作一致。 

    双击打开 coolwatcher_debughost.exe/ coolwatcher_usb.exe 的配置界面，如图 3-3-1 所示。

左侧为模块/手机型号选择区，右侧为配置项。 

 
图 3-3-1 Coolwatcher 配置界面 
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1. 根据模块/手机类型选择 Profiles 类型，如 UIS8910DM 选择 8910； 

2. 修改必要的配置项：如端口号、波特率； 

端口号为模块和 coolwatcher 的通信端口。 

  点击“OK”键，“coolhost”配置界面将会被打开，界面如图 3-3-2 所示。 

3．Coolhost 设置  

端口和波特率已在图 3-3-1 中设置，这里只需关注流控  FlowControl。 

debughost 方式的 Flow Control 为 XON/XOFF，不可修改，见图 3-3-3。 

USB 方式的 Flow Control 为 NONE，不可修改，见图 3-3-4。 

  
图 3-3-2  coolhost 界面 
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图 3-3-3 debughost 方式 coolhost 界面示意图 

 

 
图 3-3-4 usb 方式 coolhost 界面示意图 

4．是否需要发送 AT 指令？ 

Debughost 方式不需要发送任何 at 指令。 

USB 方式需用用串口工具发送 AT 指令  AT^TRACECTRL=0,1,2 启动 USB log 模式。图 3-2-1

中的 Port0 为 AT 口。 

 

4 功能说明 

Coolwatcher 主界面如图 4-1 所示。 

主界面包括：菜单栏、工具栏、log 打印区、HW Library 显示树、SW Library 显示树，寄存器

查看区，Buffer 读取区等功能区域。 
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Coolwatcher 工具可实现烧录 flash、检查 buffer 信息、读取寄存器、查看 trace 以及 dump

数据等功能。 

 
图 4-1 coolwatcher 主界面 

4.1 烧写 Flash 

该功能不支持 8910、8909L 模块。 

8910、8909L 烧写使用 FACTORYDOWNLOAD 或者 ResearchDownload 工具。 

4.2 查看 buffer 信息 

在 Buffer Watcher 中的 Address 填写地址，Size 中填写大小，点击 Poll 按钮，可以从模

块读取相关数据。 
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图 4-2-1 Buffer watcher 窗口 

4.3 查看寄存器 

把 HW Library 或 SW Library 中的某个节点拖入 Register Watcher 中，点击 pull 按钮，

可以读取并显示相关内容。 

 

   

图 4-3-1 查看寄存器 

 

4.4 查看 Trace 

4.4.1 启动 tracer 

点击菜单 Plugins->Activate Tracer，如图 4-4-1 所示，启动 Trace 插件，Trace 主界面如
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图 4-4-2 所示。 

 

 
图 4-4-1 启动 tracer 

 

图 4-4-2 Tracer 主操作界面 

 

工具栏各按钮分别对应：开始 Trace、停止、清空、设置 TraceLevels、Reapply trace levels、

保存、启动/关闭 Received 列、启动/关闭 comment。 

各列分别对应：Trace 序列号、PC 接收 Trace 时间、Tick、Level、描述等。 

4.4.2 Tracer 菜单项 

插件启动后，主菜单将显示 Tracer 项，如图 4-4-3 所示: 
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图 4-4-3 tracer 菜单项 

 

菜单项 

    Start Tracer：开始； 

    Stop Tracer：停止； 

    Clean Trace：清空 Trace 表格； 

    Clean Search：清空 Search 记录； 

    Show/Hide …：显示或隐藏 tracer 主操作界面相关功能列； 

    Set Trace Levels：设置 Trace Levels； 

    Reapply Trace Levels：重新应用 Trace Levels； 

    Reload DB：重新加载 DB 文件； 

    LoadSettings：加载 Levels 配置； 

    SaveSettings：保存 Levels 配置； 

    Load TFG：加载 tfg 文件； 

    Save TFG：选择保存 T 卡 Trace 文件； 
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    Load bin: 加载二进制 Trace 文件，进行 log 回放； 

    Save Trace（bin/trc）：保存 trace。 

 

图 4-4-4 Tracer Show/Hide 菜单 

 

当图 4-4-4 中选项被勾选时，则在图 4-4-2 的主界面中增加相应的一列，来显示相关内容。 

菜单选项： 

    Toggle Raw Data: 启动/关闭 Raw 表格； 

 

图 4-4-5 RawData 窗口 

 

    Index：Trace 序列号； 

    Received Time：PC 接收到 trace 的时间； 

    Tick：各 trace 对应的 tick，显示的 tick 只有 16bits，16KHz； 

    SN：SN 是 16bits 序列号，可以用来判断丢 trace 的情况，当 trace 没有丢失时 SN 列

为空。 

ShowInvalidTrace  启动／关闭无效 trace 表格. 如下图，包括没有使用 TraceID、解
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析失败、ＳN 有中断等三个表格。 

 
图 4-4-6 无效 trace 窗口 

4.4.3 Tracer 应用步骤 

1. 设置 TraceLevels 

点击 按钮，设置 tracelevel，显示如图 4-4-7。需在左侧表格中选择关注的 levels； 

AutoSave  

 check 是否自动保存 trace，状态为 checked，则自动保存。 

 bin、trc：为 trace 文件类型，前者为二进制文件，后者为文本文件; 

 Split Size： trace 文件大小。当文件 size 超过该值时，自动切分文件； 

DB file name 

       DB 文件名。 

RowLimit 

       图 4-4-2 的 Trace 表格的最大行数； 

Auto reapply trace levels on reset 

       重启前的 TraceLevels 配置信息是否用于重启后。 

Tick in flow ID 0x80 

       该配置项需与 lod 保持一致，如果 lod 中有时间戳，则选中本项，否则不选。 
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ReceiveEvent 

       是否接收 Event。 

Save Pcap 

       是否保存 Pcap 信息。 

 

左下角按钮 

  Save 按钮：保存 Levels 配置； 

  Load 按钮：加载 Levels 配置； 

 

 

图 4-4-7 trace level 界面设置 

 

2. 点击图 4-4-8 中的  按钮，开始 Trace 功能，Trace 信息会显示到表格中。 
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图 4-4-8 tracer 显示界面 

3. 点击图 4-4-8 中的 按钮，结束 Trace 功能； 

注意：Tracer 的配置信息，默认为 rbbase\common\plugins\tracer\ 文件夹中的文件。 

4.5 GDB 分析 

GDB 是分析死机、跟踪问题的一种重要方法。除了 gdb 常见命令外。还可以查看 CPU 寄

存器和变量。 

4.5.1 启动 GDB 

      点击菜单项 Tools->GDB Launcher，启动 GDB 配置框，见下图。 

   

图 4-5-1 启动 GDB 

 GDB server Port：默认值即可，不可修改。 

 ELF 文件：与芯片版本对应的 elf 文件。 
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 GDB Executable :  和 Mode 有关，Mode 为 8910AP 或者 8910CP 时，不需要选择 GDB 

Executable； 选择其他 mode 时，选择 mips-gdb\bin 中的 mips-elf-insight.exe 文件。 

       
图 4-5-2 GDB Executable 不可选示意图 

 

 

 

图 4-5-3 GDB Executable 可选示意图 

 Mode 

      有 7 种模式，“bare”、 “sx(with REDUCED_REGS) ”、 “sx(without REDUCED_REGS) ”、

xcpu_rom、live、8910 AP 以及 8910 CP。“sx”相比“bare”启动的 gdb 多了两个命令，thread info

和 thread; “xcpu_rom”一般用于系统启动之前的死机；“live”模式一般用于严重的死机分析。 

• 8910 只能使用 8910AP 或者 8910CP。 

• 其他模块一般情况下使用“bare”模式即可。          

      点击图 4-5-1 或 4-5-2 的 Launch 按钮后，会弹出如下界面： 
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图 4-5-4 GDB 源码窗口 

4.5.2 察看调用栈 

     点击图 4-5-4 工具栏上的 Console 按钮 ，启动 gdb 命令行终端窗口。可以使用 gdb 命令来

看想要的信息，我们用得最多的是 bt，查看 back trace。bt f 则会更详细的展示一些局部变量的值 

 
图 4-5-5 GDB 命令行 
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图 4-5-6 GDB 分析结果显示 

4.5.3 察看变量 

 

     打开查看变量的窗口 ，可以查看全局的 symbol。如果知道某个变量在某个地址，也可以把地

址强制转换成特定类型查看。 

 

图 4-5-7 GDB 查看变量窗口 
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4.5.4 察看寄存器 

     点击查看寄存器的按钮 ，可以看到所有的 cpu 寄存器。8910 项目，展示的是 ARM 的寄存器。 

 

图 4-5-8 GDB 查看寄存器窗口 

4.5.5 GDB 常用命令 

 

 

ID 
GDB 命令 

注释 

1 p<sth>(print <sth>) 

打印 sth 的值，sth 可以是一个表达式、变量、

指针等。 

2 display <sth> 

和“p sth”相同，不过 display 会在你每次输

入命令后显示 sth 的值。 

3 

bt or bt f (backtrace or backtrace 

full) 

Aacktraces (backtraces full) the current 

executed code. You get the call stack, 

parameters passed to each function, & so 

on. By using "full" you will also get the 

display of all local variables for these 
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functions (EXTREMELY useful). 

4 
up 

Goes up into the call stack. To be used in 

conjonction with bt. 

5 
down 

Goes down into the call stack. To be used 

in conjonction with bt. 

   

 

4.6  Profile 分析 

Profile 是分析问题的一种重要方法，呈现了软件运行时 CPU 在做什么，比如可以看出某时刻

某 task 在运行，某时刻中断在运行。 

模块不同方法有所差异。 

4.6.1 抓取 Profile 文件 

4.6.1.1 8910 及后续模块 

通过菜单项 Tools -> Profile Dump (v2.0)，图 4-6-1，启动 Profile Dump，主界面如图 4-6-2

所示。 

 

图 4-6-1 启动 Profile Dump (v2.0) 
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选择对应 ELF 文件，和对应输出文件，点击 OK； ELF 文件是版本发布的 elf 文件，一定要和

版本对应。 

 
图 4-6-2 Profile Dump 主界面 

 

显示下面展示的信息说明 dump 成功。 

 

图 4-6-3 Profile Dump 成功提示信息 

4.6.1.2 8955、8908、8909 等模块 

      点击 coolwatcher 主界面中的 Plugins->Activate BufferProfile 菜单项，如图 4-6-4，启动

Buffer Profile 插件，主菜单上会出现 BufferProfile 菜单，工具栏上会有相关按钮。 

 

 图 4-6-4 启动 buffer profile  
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图 4-6-5  bufferProfile 菜单示意图 

 

      模块死机后，可以通过该插件抓取有关信息。使用方法如下： 

  手机通过 COM 口与 PC 机相连，保证可以与 coolwatcher 正常通信。 

  点击图 4-6-5 中 Choose save PRF file 菜单项，或工具栏上的 按钮，输入要保存的*.prf

文件，文件的默认路径与 coolwacher.exe 路径一致。 

  点击图 4-6-5 中 Start XCPU dump and parsing 菜单，开始保存 XCPU 相关信息。类似信

息如下图： 

 

图 4-6-6 保存 XCPU 相关信息 

 如点击图 4-6-5 中 Start BCPU dump and parsing 菜单，则保存 BCPU 相关信息。类似信

息如下图： 
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图 4-6-7 保存 BCPU 相关信息 

 如点击图 4-6-5 中 Start dump and parsing 菜单，则保存 BCPU 和 XCPU 两者的信息。

Coolwacher 输出如下图： 

 
图 4-6-8 保存 XCPU 与 BCPU 信息 

注意： 

如果模块没有死机，抓取*.prf 之前，需点击菜单项中的 Pause buffer profile 项，文件保存

完成后，点击 Resume buffer profile 菜单项，恢复状态。 

 

图 4-6-9 未死机/蓝屏时保存 profile 文件 

4.6.2 察看 profile 信息 

打开 coolprofile.exe 工具 ，如图 4-6-10 所示。 
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图 4-6-10 coolprofile 工具主界面 

 

打开后在菜单栏选择，Open dump。 

 

图 4-6-11 选择 open dump 加载文件 

 

之后会弹出图 4-6-12 的 coolprofile 的文件选择窗口，需要选择 dump file 和 config 文件，

之后点击 OK。 

xcp 文件选择：8910  8910.xcp； 8955 8809.xcp; 8908/8909  8909.xcp 
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图 4-6-12 选择 open dump 加载文件 

 

打开后可以看到图 4-6-13 的界面。 

 

图 4-6-13 加载文件后的工具界面显示 

 

按照图 4-6-13 所提示的的方式拖拽，可以看到图 4-6-14 示的波形。 
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图 4-6-14 加载文件后的工具界面显示 

 

可以通过鼠标操作右边波形进行图形的缩放：使用鼠标右键拖拽是放大，单机鼠标右键是缩

小。鼠标左键按下可以设置一条竖直的线，按下鼠标中键（滚轴）是设置一个长期的竖直的线（左

键在其他地方按下之前的线会消失）。图 4-6-15 中线条为高，代表 CPU 正在运行这部分 function。

可以通过两条竖直的锚线来测量一段代码运行的时间。 
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图 4-6-15 放大后的波形图与鼠标操作示意 

4.7 离线分析 

4.7.1  准备*.cmm 或者*.elf 文件 

    参考 4.10.1 章节进行蓝屏导出。 

4.7.1.1 8910 及后续模块 

    8910 及后面模块死机后，利用 4.10 章节的蓝屏导出功能导出*.cmm 文件。 

4.7.1.2 8955、8908 及 8909 模块 

    8955 模块 assert 后，利用 elfdump 命令可以生成*.core(*.elf)文件。抓取*.core(*.elf)文件的命

令见章节 4.14 ，举例如下: 
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图 4-7-1 生成 elf 文件 

4.7.2 建立离线分析环境 

     coolwatcher 支持将蓝屏 dump 文件导入，实现离线分析。 

     首次使用离线分析，不是特别熟悉的情况下，建议关闭电脑上的所有 coolwatcher 和 coolhost，

之后再搭建离线分析环境。 

4.7.2.1 8910 及后续模块 

启动 coolhost.exe 程序，主界面如下： 

 

图 4-7-2coolhost 主界面 

 配置端口 
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        Port 端口号，可以随意定，如 20，图 4-7-2 中的 port 值计算方法为 7700+PortNum，所

以填写 7720； 

       点击 Start TCP Server 按钮； 

 加载 dump 蓝屏文件 

      点开 DATA tab 页，右键点击 Add 菜单项，如下图 4-7-3，选择*.cmm 文件，如图 4-7-4 所示。 

 

图 4-7-3  加载 dump 文件 

 

 

图 4-7-4  选择*.cmm 文件 
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 点击图 4-7-4 的 load 按钮，加载文件。 

 启动 coolwatcher 

点击 coolwatcher*.exe， 下图中的 lastcomport 项的数值要与图 4-7-4 中 Port 

的后两位保持一致，如 Port 选择 7720，lastcomport 项的值则为 20。 

 
图 4-7-5 设置 lastcomport  

 

启动 coolwatcher 后，即可进行离线分析。 

4.7.2.2 8955、8908 及 8909 模块 

启动 coolhost.exe 程序，主界面如图 4-7-2。 

 配置端口 

      Port 端口号，可以随意定； 

      点击 Start TCP Server 按钮； 

 加载 dump 蓝屏文件 
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      点开 DATA tab 页，右键点击 Add 菜单项，如下图，选择*.core（*.elf）文件和 lod 文件，如

图 4-7-7 所示。 

      注意，先选择*.core（*.elf）文件；该*.core（*.elf）文件用 elfdump 命令生成的文件，不是和

lod 一起发布的 elf 文件。 

 

图 4-7-6 加载 elf 文件 

 

 

图 4-7-7 选择 elf 文件路径 

 

    点击图 4-7-7 的 load 按钮，加载文件，效果如下图： 
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图 

图 4-7-8 加载数据后界面显示 

 启动 coolwatcher 

点击 coolwatcher*.exe， 下图中的 lastcomport 项的数值要与图 4-7-6 中 Port 

的后两位保持一致，如 Port 选择 7720，lastcomport 项的值则为 20。 

 

 

图 4-7-9 设置 lastcomport 

 

启动 coolwatcher 后，即可进行离线分析。 
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4.7.3 离线分析 GDB 

保持 4.7.2 环境不变，安照步骤 4.5 进行 GDB 分析。 

4.7.4 Elf Data Check 

该功能主要用于 8955、8908、8909 模块。 

用于比较 dump 和原始 elf，检查代码是否有被改写。 

启动过程 

利用 4.7.2 章节介绍搭建离线环境后，点击Tools->Elf Data Check 菜单，启动主界面图 4-7-11： 

 

 

图 4-7-10 选择 Elf Data Check 

 

  
图 4-7-11 Elf Data Check 主界面 

  操作步骤： 

1． 点击上图中的“load”按钮，选择与 lod 一起发布的*.elf 文件，点击“Check”按钮后如下图: 
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图 4-7-12 load elf 文件后界面显示 

2． 选择待比较的项 

通过操作首列 check box，选择待比较的项： 

 

图 4-7-13 选择比较项 

 

3． 比较和保存结果 

点击图 4-7-12 中的 check 按钮，如果有不同，则会弹出下对话框： 

 

图 4-7-14 错误提示 

点击 OK 按钮，选择/填写要保存的文件： 
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图 4-7-15 保存对比报告 

不同处将会保存到文件中，效果如下图： 

 

图 4-7-16 对比报告中不同处对比 

4.8 Heap Report 

 HeapReport 功能有两个插件，一个是 SX Heap Report，一个是 HeapReport（New）。 

 模块不同使用不同的插件，如 8910 模块使用 HeapReport（New）。 
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图 4-8-1 Heap Report 菜单 

4.8.1 生成 heapreport 文件 

 

4.8.1.1  8910 及后续模块 

     8910 及后续模块使用 Heap Report (new)。 

 参考图 4-8-1，点击 Tools -> Heap Report (new)，启动 Heap Report (new)，如图 4-8-2。 

 

图 4-8-2 启动 Heap Report (new) 

 弹出菜单中选择对应 ELF 文件，导出的目标文件(txt 文本)；ELF 文件为与 pac 固件一起发布的

elf 文件。点击 Start，显示下面红框中信息就代表导出成功。 
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图 4-8-3 Heap Report (New)执行成功示意图 

4.8.1.2 8955、8909、8908 等模块 

8955、8909、8908a 等模块保存 HeapReport 信息，需使用 SX Heap Report 插件。 

点击主菜单 Tools->Heap Report 项，启动 Heap Report 设置对话框，如图 4-8-4。 

  

图 4-8-4 Heap Report 对话框 

 

     Elf 文件：与 lod 一起发布的 elf 文件； 

 

图 4-8-5 选择 elf 文件 

 

      Report File：导出的目标文件。 

      选择或填写相关信息，点击 Run 按钮，生成 Report File，示例如下： 
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图 4-8-6 生成 Report File 示意图 

4.8.2 分析 heap report 

查看 heap report 没有什么特殊技巧，主要是根据信息和经验，如果有某个函数反常得申请过很

多内存未释放，就很可能有内存泄漏。8955/8908/8909 导出得报告格式和 8910 以及以后芯片有所

不同，但是反映得信息是一样的。 

4.9 Register Viewer 

RegisterViewer 工具可以按 bit 位读取、编辑寄存器，同时具有查找功能。 

点击主菜单 Tools->Register Viewer 项，如图 4-9-1，启动 Register Viewer 页面，见图 4-9-2。 
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图 4-9-1 启动 Register Viewer 

 

  

图 4-9-2 Register Viewer 主界面 

4.10 Blue Screen Dump  

4.10.1 抓取蓝屏数据 

4.10.1.1  8910 及后续模块 

8910 及后续模块使用 Blue Screen Dump 工具。 

通过 toolsBlue Screen Dump 启动 Blue Screen Dump 主界面，如图 4-10-2 所示。 
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图 4-10-1 启动 Blue Screen Dump 

 

 

图 4-10-2 Blue Screen Dump 主界面 

    属性设置 

Mode： ARM dump bin only、MIPS dump bin only、8910(FreeRTOS)、8909(FreeRTOS)、

8955(FreeRTOS)五种模式，根据不同的芯片，选择不同的 mode。8910->8910(FreeRTOS)。 

 

图 4-10-3 Blue Screen Dump 5 种 Mode 

 

XML： 用缺省的 elfdump xml 文件； 

Output Directory： dump 文件输出目录，每次 dump 需选择新的目录； 

STUB_PERI : 默认 checked 状态 ，为快速 dump 模式 (software stub,with 

ADI/ISPI/RFSPI)。选中该模式时，工具会优先设置快速模式，如果设置失败，则用原有的 dump 模



 

53 

式。 

注意： 

如果 dump 失败，在 command 窗口输入‘r 0’测试下读取功能，如果读取失败，需先执行

‘creconnect’命令，再执行‘r 0’。读取正常的情况下，如果 STUB_PERI 模式仍然失败，则需把

改为 unchecked 状态 。 

    Log 信息 

    蓝屏导出过程的 log 信息会保存在与 dump *.bin 文件相同的文件夹中， 命名格式为 dump_*.log，

内容示例如下。 

 

图 4-10-4 Blue Screen Dump  log 信息 

4.10.1.2 8955、8908、8909 等模块 

8955、8908、8909 等模块死机后，利用 elfdump 命令可以生成*.core(*.elf)文件，举例如

下: 

 

图 4-10-5 elfdump 指令示意图  
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4.10.2 蓝屏分析 

1. 8910 蓝屏分析 

• 分析 AP 

          把 AP 的 ELF 拷贝到 dump 目录下，重命名为 ap.elf； 

           把 ap.cmm 拖到 TRACE32 中即可； 

• 分析 CP 

          把 CP 的 AXF 拷贝到 dump 目录下，重命名为 cp.axf（通常就是这个名字）； 

          把 cp.cmm 拖到 TRACE32 中即可； 

2. Dump 中目前包含 PMIC 寄存器，如果有需要后续还会添加； 

3. AP FreeRTOS 切换 task 目前还不工作； 

4. Cmm 也可以通过 coolhost 离线加载，参考 4.7 章节； 

       Coolhost 加载 ap.cmm 或者 cp.cmm 是一样的；  

       离线加载*.cmm 后，可以利用 GDB 插件进行分析。 

4.11 Access Mode 

    Note：谨慎使用本功能。 

通过 Tools -> Access Mode 启动该功能。 

 

图 4-11-1 Access Mode 三种模式 
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   现在 coolwatcher 读写有三种模式: 

 DebugHost 硬件； 

 给 CPU 发命令，由 CPU 执行并返回； 

 给 CPU 发命令，由 CPU 执行并返回，同时 CPU 处理特殊地址； 

• 8910DM：通过正常 ADI BUS 的操作方法读写 PMIC 寄存器； 

  建议只有读写 PMIC 时切换模式，不使用读写 PMIC 的功能时一定记得切回 Hardware 

DebugHost 模式。 

4.12 芯片控制 

工具提供了下列常用的对芯片进行控制的操作功能，大大提高了用户调试过程中对手机硬件控制

的能力。 

4.12.1 关闭芯片 

点击工具条按钮 ，可以控制模块关机。 

4.12.2 重新启动芯片 

点击工具条按钮 ，可以控制手机或开发板重新启动，便于调试用户程序。 

4.12.3 芯片强制死机 

点击菜单项“Chip -> Force panic”，可以强制芯片死机，如图 4-13-1。 
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图 4-12-1 芯片强制死机 

Force panic 是通过 DebugUart 给 CPU 发命令，如果 CPU 不能处理 DebugUart 命令（例如在

高优先级 task 里面死循环），则无法触发 CPU 死机。 

4.12.4 其他 chip 操作 

图 4-13-1 中所示，除去芯片强制死机外，还涉及到其他芯片操作，介绍如下： 

• Chip -> Power off：关机； 

• Chip -> Reboot：重启； 

• Chip -> Reboot to download：重启进入 ROM 强制下载； 

 这个不是取代 FORCE DOWNLOAD PIN，而是提供更方便的手段，可靠性不如 PIN。

正规进入下载模式的方法是 FORCE DOWNLOAD PIN； 

• Chip -> Reboot to calib：重启进入校准模式； 

 正规进入校准模式的方法是 SIMBA ENTER MODE； 

• Chip -> Reboot to BBAT ：重启进入 BBAT 模式； 

 正规进入 BBAT 模式的方法是 BBAT ENTER MODE； 

4.13 串口数据的 trace 回放 

  此功能仅适用的场景：因条件限制不能用 coolwatcher 抓取、保存 trace。借用其他工具把从
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UART 口输出的数据保存为二进制文件，并且需要用 coolwatcher 分析数据中的 trace。 

1. 抓包工具(客户自行修改) 

 工具保存 UART 数据时，需增加时间戳信息，增加规则如下： 

 抓包工具创建 LOG 文件时，自动插入一个 timestamp 的 HOST 包； 

 如果 UART 一段时间没有数据（例如 1 秒），自动再插入一个 timestamp 的 HOST 包； 

 如果 UART 长时间没有数据，每秒插入一个 timestamp 的 HOST 包； 

 支持自动分段功能，避免极大的二进制文件，单个文件不超过 10M； 

2. Coolwatcher 适配 

 coolwatcher 导入 UART 数据时，会处理包含时间戳信息的 HOST 包，使用时间戳 HOST 包的

时间，在下一个 timestamp 到达之前用 tick 累加。 

3. 时间戳 HOST 包格式 

 包结构如下： 

     struct CH_TIMESTAMP { 

            quint8 sync; 

            quint8 lenM; 

            quint8 lenL; 

            quint8 flowid; 

            quint32 date; 

            quint32 ms; 

 

            TIMESTAMP (){ 

               sync= 0xAD; 

               lenM = 0; 

               lenL = 0x08; 

               flowid = 0xa2;  

               date = 0; 

               ms = 0; 

            } 

}; 

 sync、lenM、lenL、flowid: 均用默认值，且不能修改； 
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 date：利用公式“year << 16 +  month << 8 + day”计算 date。year、month、

day 分别代表年月日； 

 ms ：毫秒 从 0 点至当前时间的总毫秒数； 

 大小端： 时间戳 HOST 包用小端方式保存。 

4. Coolwatcher 如何回放 UART 数据 

主菜单 Tracer->Load Trace (bin)，选择串口数据保存的*.bin 文件。 

 
图 4-13-1  UART 数据回放菜单 

           包含时间戳信息的 Uart 数据包在 coolwatcher tracer 显示窗口中的效果见下图。 



 

59 

 
图 4-13-2 时间戳信息显示示意图 

4.14 命令行操作 

本工具提供了一些开发中常用的操作命令，用户可以很方便的在命令行输入框输入这些命令，完

成相应的操作，并将操作结果显示在“Ruby script”框内。 

4.14.1 端口操作 

常用的端口操作命令如下列表： 
5.  

命令 参数 示例 备注 

copen (NUM,BR=BR_AUTOMATIC) copen(2,115200) 打开 COM2 

reop  reop 重新打开当前端口 
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4.14.2 Flash 编程 

常用的 Flash 编程命令如下列表： 

命令 参数 示例 备注 
 

fastpf 

(flash_programmer_filename, 

lod_filename, 

disable_event_sniffer = true) 

fastpf(“c:\xxxx_ramrun.l

od”,” ”c:\\lod”) 

烧写 Flash 

不能用于 8910

和 8909L 模块 
 

fastSectorEraser 

(flash_programmer_filename, 

sector_list, disable_event_sniffer 

= true) 

fastSectorEraser(“c:\xx

xx_ramrun.lod”,” 

[0x01000000,0x012000

00] ”) 擦除扇区 
 

 

4.14.3 读 Flash 

常用的读 Flash 操作命令如下列表 

命令 参数 示例 备 注 

r (addr) r  x01004000 32 位写 

r32 (addr) r32  0x01004000 32 位写 

r16 (addr) r16  0x01004000 16 位写 

r8 (addr) r8  0x01004000 8 位写 

 

4.14.4 写 Flash 

常用的写 Flash 操作命令如下列表 
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命令 参数 示例 备注 

w (addr,val) w(0x01004000,0xffffffff) 32 位读 

w32 (addr,val) W32(0x01004000,0xffffffff) 32 位读 

w16 (addr,val) W16(0x01004000,0xffff) 16 位读 

w8 (addr,val) W8(0x01004000,0xff) 8 位读 

 

4.14.5 其他命令 

 

命令 参数 示例 

elfdump elf 文件 [,xml 文件名] 

xml 文件名可以不写，如果写需要

给出绝对路径 

elfdump “test.elf” 或 者

elfdump 

“test.elf” ,“D:/8809.xml” 

dump (str_filename,address,nbwords)

,读取一段连续的 flash 区域到指定

文件。 

Dump(“c:\\xxxx.bin”,0x0100

4,0x100) 

chipID 无参数，直接返回芯片 ID 000,0x1000) 

flashReadStatus 无参数  

flashSectorErase flashSectorErase(addr)  

flashBlockErase flashBlockErase(addr)  

flashBlock32kErase flashBlock32kErase(addr)  

flashChipErase flashChipErase()  

xcvRead xcvRead(addr)  



 

62 

xcvWrite xcvWrite(addr,data)  
 

 

4.15 其他功能 

4.15.1 Kill 当前运行的程序 

点击菜单项“File->Kill command thread” 或工具条按钮 ，可以强制终止当前正在运行的

程序（一般为用户在命令行输入的命令线程）。 

4.15.2 Kill 所有运行的程序 

点击菜单项“File->Kill all threasd”，可以强制终止正在运行的全部（一般为用户在命令行输入

的命令线程）。 

4.15.3 清除脚本输出信息 

点击菜单项“View->Clear Screen”或工具栏按钮 ，可以清空左下方的“Ruby script”区域

的输出信息。 

4.15.4 寄存器读写注意事项 

    8910 模块 不能读取 INT_REG_DBG_HOST 寄存器。 
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图 4-15-1  8910 INT_REG_DBG_HOST 寄存器示意图 
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